CMS SmallNuke система построения сайтов

Здравствуйте, гость ( Вход | Регистрация )

3 страниц V < 1 2 3  
Ответить в эту темуОткрыть новую тему
> Настройка, финальная настройка- траблы
Duba
сообщение 28.10.2005, 09:58
Сообщение #41


Активный участник
***

Группа: Пользователи
Сообщений: 1 364
Регистрация: 02.02.2005
Из: Nizhny Novgorod, Russia
Пользователь №: 973



Этот файл ложится в системную диру когда просто отдельно ставишь майскул. Если денвер целиком, то скорее всего в дире с денвером или самим майскулом.


--------------------
Право - это не только право...
"Нижегородский адвокат"
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
rigiy
сообщение 28.10.2005, 15:51
Сообщение #42


Активный участник
***

Группа: Пользователи
Сообщений: 47
Регистрация: 07.10.2005
Из: С-Пб. Россия > Israel
Пользователь №: 2 391



dry.gif Да же и незнаю, что делать. Не идет смола, и все тут. Снова все удалил, почистил. Переустановил с АппСерв тот же результат. Почему форум нормально работает ( регистрация, вход админа , юзверя ... ). Попробую на сервере в"он-лайн" проверить, правда только через неделю смогу, Мускул пока отключен, а что бы включить нужно оплатить smile.gif


--------------------
aut Caesar
aut nihil
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
rigiy
сообщение 03.12.2005, 10:20
Сообщение #43


Активный участник
***

Группа: Пользователи
Сообщений: 47
Регистрация: 07.10.2005
Из: С-Пб. Россия > Israel
Пользователь №: 2 391



smile.gif Вот и все!
Все заработало. Проблема была с виндой. Короче поймал какую то гадость и поэтому, что то перевернуло в настройках. Переустановил винду, залил Смолу, форум и заработало. tongue.gif
Правда редактор в опере отображается без вспомогательных иконок, в эксплорере все нормально. И еще, ставил через Денвер там уже есть Zend, но при соединении сайта и форума (одновременная регистрация) пишет нужен Zend. Скачал и устоновил с сайта последнюю версию Zend инсталировал его ( при инсталяции он спрашивает где что лежит wink.gif все базы) и опять тишина.


--------------------
aut Caesar
aut nihil
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
MNU
сообщение 04.12.2005, 12:10
Сообщение #44


Администратор
Group Icon

Группа: Администраторы
Сообщений: 3 577
Регистрация: 26.10.2005
Пользователь №: 2 498



По поводу регистраций в соотвествующие разделы форума (в зависимости от типа форума).


--------------------
Правильно заданый вопрос - 50% ответа...
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Заварка
сообщение 09.06.2009, 10:51
Сообщение #45


Активный участник
***

Группа: Модераторы
Сообщений: 450
Регистрация: 10.08.2005
Из: КИЕВ!
Пользователь №: 2 071



Дуба написал интересную мысль.
"Где-то в топиках было про проблему с браузерами, т.е. с парсингом определеня каким браузером юзаем. Там решение корректное,"

так и есть. в ие, коньюерор заходит к примеру, в фф3 не заходит smile.gif


--------------------
SmallNuke ВКонтакте
-------------------------------------------------
Читать Всем, у кого возникли вопросы касающиеся работы системы:
Как описывать технические проблемы
ИзображениеИзображениеИзображение
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Заварка
сообщение 09.06.2009, 11:17
Сообщение #46


Активный участник
***

Группа: Модераторы
Сообщений: 450
Регистрация: 10.08.2005
Из: КИЕВ!
Пользователь №: 2 071



проблему выявить не сложно.
в admin.php можно вывести на экран запрос который идет в бд, в случае не удачи идет переадресация.

проблема в ф.explode там идет разбиение строки по знаку двоеточие, а , например в ФФ3, агент вот такой вот: smile.gif
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7

соответственно admin.php сверяет след. строки:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv (это тот агент который ловит админ.пхп)
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7 (это в базе)
ессно проверку это не проходит, т.к. строки разные и получается переадресация.

решение вижу такое: использовать другой разделитель

для админа:
файл admin/admin.php

~60 строка:
Код
    $_SESSION['admin_cn'] =  base64_encode("".$checknum.":".$agent."");


меняем на :
Код
    $_SESSION['admin_cn'] =  base64_encode("".$checknum.":::-:::".$agent."");


~76 строка:
Код
    $ch_num = explode(":", $cn_num);

меняем на:
Код
    $ch_num = explode(":::-:::", $cn_num);


для юзверей:

файл inc/auth_function/system.php


~105 строка:
Код
    $info = base64_encode("".$setuid.":".$setusername.":".$user_actkey.":"._SN_USERAGENT."");

меняем на:
Код
    $info = base64_encode("".$setuid.":".$setusername.":::-:::".$user_actkey.":"._SN_USERAGENT."");


~48 строка:
Код
    $ses_user = explode(":", $ses_user);

меняем на:
Код
    $ses_user = explode(":::-:::", $ses_user);


p.s.: для пользователя не проверял, бо у на моем сайте 2.0 финале не предусмотрена работа с пользователями. но имхо должно работать, если не работает - пишите, помогу.


--------------------
SmallNuke ВКонтакте
-------------------------------------------------
Читать Всем, у кого возникли вопросы касающиеся работы системы:
Как описывать технические проблемы
ИзображениеИзображениеИзображение
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения

3 страниц V < 1 2 3
Ответить в эту темуОткрыть новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



Текстовая версия Сейчас: 25.09.2017, 21:55